Dica de Excel: Verificando se uma data é um dia útil ou não

A dica de hoje vamos criar uma função para verificar se uma data é um dia útil ou não, para tal vamos utilizar as funções SE, OU e DIA.DA.SEMANA.

Digitar numa célula uma data qualquer:

ex115

Não esqueça também de criar uma lista para os feriados do ano. No exemplo há apenas alguns, mas você pode incluir mais na coluna C.

ex214

Agora na célula em que você deseja que apareça se a data é um dia útil ou não, digite a seguinte fórmula:

=SE(OU(DIA.DA.SEMANA(A1)=1;DIA.DA.SEMANA(A1)=7;C:C=A1); “Não é dia Útil”;”É dia Útil”)

ex39

Vamos entender a fórmula:

A função DIA.DA.SEMANA retorna o número referente ao dia da semana de uma data especificada.

A função OU verifica se um ou mais valores lógicos especificados são verdadeiros. Se pelo menos um for verdadeiro a função retorna VERDADEIRO.

A função SE faz um teste lógico. Você pode determinar o que ela retornará se for verdadeira ou falsa.

Em nossa fórmula, a função OU verifica se o dia da semana retorna 1 (Domingo) ou 7 (Sábado) ou uma data que está na matriz de feriados (C:C) é igual a data que está sendo verificada. Se uma dessas comparações forem verdadeiras, ou seja, se a data especificada for Domingo ou Sábado ou um feriado, a função retorna “Não é dia Útil”. Se falsa retorna “É dia Útil”.

Até a próxima.

Anúncios

About carlosfabiano

Analista de infraestrutura e Segurança Professor de Tecnologia da Informação

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: